- Update to 0.3.0

- Add WITHOUT_GLITZ OPTION [1]
- Add WITHOUT_X11 knob

Requested by:	debugger via irc [1]
This commit is contained in:
Michael Johnson 2005-02-16 05:52:43 +00:00
parent 267630c0bb
commit 636327204c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128991
5 changed files with 36 additions and 54 deletions

View File

@ -6,16 +6,14 @@
#
PORTNAME= cairo
PORTVERSION= 0.2.0
PORTVERSION= 0.3.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ahze
MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= ahze@FreeBSD.org
COMMENT= Cairo is a vector graphics library with cross-device output support
LIB_DEPENDS= pixman.1:${PORTSDIR}/graphics/libpixman \
glitz-glx.1:${PORTSDIR}/graphics/glitz \
freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png
@ -26,12 +24,15 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CLFAGS}" \
LDFLAGS="${PTHREAD_LDFLAGS}"
PLIST_FILES= include/cairo-features.h \
include/cairo.h \
lib/libcairo.a \
lib/libcairo.so \
lib/libcairo.so.1 \
libdata/pkgconfig/cairo.pc
OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
.if defined(WITH_GLITZ)
LIB_DEPENDS+= glitz-glx.1:${PORTSDIR}/graphics/glitz
.endif
.if !defined(WITHOUT_X11)
USE_XLIB= yes
.endif
.include <bsd.port.pre.mk>

View File

@ -1,2 +1,2 @@
MD5 (cairo-0.2.0.tar.gz) = 2ff2b3b52b862971d2baa3fede3a3d6e
SIZE (cairo-0.2.0.tar.gz) = 462216
MD5 (cairo-0.3.0.tar.gz) = 78c1a536d3a45bdc06a8335d33e63d8f
SIZE (cairo-0.3.0.tar.gz) = 514446

View File

@ -1,27 +1,15 @@
--- src/cairo_font.c.orig Tue Nov 9 21:51:24 2004
+++ src/cairo_font.c Tue Nov 9 21:53:06 2004
@@ -54,9 +54,9 @@
static unsigned long
_font_cache_hash (void *cache, void *key)
{
+ unsigned long hash;
cairo_font_cache_key_t *in;
in = (cairo_font_cache_key_t *) key;
- unsigned long hash;
/* 1607 and 1451 are just a couple random primes. */
hash = _cairo_hash_string (in->family);
@@ -86,11 +86,12 @@
--- src/cairo_font.c.orig Thu Jan 13 09:37:40 2005
+++ src/cairo_font.c Wed Feb 16 00:50:47 2005
@@ -85,9 +85,11 @@
void *key,
void **return_value)
{
+ const struct cairo_font_backend *backend;
- const cairo_font_backend_t *backend = CAIRO_FONT_BACKEND_DEFAULT;
+ const cairo_font_backend_t *backend;
cairo_font_cache_key_t *k;
cairo_font_cache_entry_t *entry;
+
+ backend = CAIRO_FONT_BACKEND_DEFAULT;
k = (cairo_font_cache_key_t *) key;
- const struct cairo_font_backend *backend = CAIRO_FONT_BACKEND_DEFAULT;
+ backend = CAIRO_FONT_BACKEND_DEFAULT;
/* XXX: The current freetype backend may return NULL, (for example
* if no fonts are installed), but I would like to guarantee that

View File

@ -1,23 +0,0 @@
--- src/cairo_ft_font.c.orig Tue Nov 9 21:53:24 2004
+++ src/cairo_ft_font.c Tue Nov 9 21:58:25 2004
@@ -481,6 +481,9 @@
cairo_glyph_t **glyphs,
int *nglyphs)
{
+ double x, y;
+ FT_ULong *ucs4 = NULL;
+ size_t i;
cairo_ft_font_t *font = abstract_font;
FT_Face face = font->val->face;
cairo_glyph_cache_key_t key;
@@ -490,9 +493,7 @@
key.unscaled = &font->base;
key.scale = *sc;
- double x = 0., y = 0.;
- size_t i;
- FT_ULong *ucs4 = NULL;
+ x = 0., y = 0.;
_utf8_to_ucs4 (utf8, &ucs4, nglyphs);

16
graphics/cairo/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
include/cairo/cairo-atsui.h
include/cairo/cairo-features.h
include/cairo/cairo-ft.h
include/cairo/cairo-glitz.h
include/cairo/cairo-pdf.h
include/cairo/cairo-png.h
include/cairo/cairo-ps.h
include/cairo/cairo-quartz.h
include/cairo/cairo-xcb.h
include/cairo/cairo-xlib.h
include/cairo/cairo.h
lib/libcairo.a
lib/libcairo.so
lib/libcairo.so.1
libdata/pkgconfig/cairo.pc
@dirrm include/cairo