Add kmuddy, a MUD client for KDE.

This commit is contained in:
Michael Nottebrock 2007-02-25 18:16:38 +00:00
parent 4e3eaf53ed
commit 6301751293
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185913
8 changed files with 7927 additions and 0 deletions

View File

@ -231,6 +231,7 @@
SUBDIR += keepalived SUBDIR += keepalived
SUBDIR += kiax SUBDIR += kiax
SUBDIR += kissd SUBDIR += kissd
SUBDIR += kmuddy
SUBDIR += knemo SUBDIR += knemo
SUBDIR += kojoney SUBDIR += kojoney
SUBDIR += kphone SUBDIR += kphone

40
net/kmuddy/Makefile Normal file
View File

@ -0,0 +1,40 @@
## New ports collection makefile for: kmuddy
# Date created: 2007-02-25
# Whom: Michael Nottebrock <lofi@kiste>
#
# $FreeBSD$
#
PORTNAME= kmuddy
PORTVERSION= 0.8
CATEGORIES= net games
MASTER_SITES= http://www.kmuddy.com/files/
MAINTAINER= lofi@freebsd.org
COMMENT= MUD client for KDE
LIB_DEPENDS= mxp:${PORTSDIR}/net/libmxp
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
USE_GETTEXT= yes
USE_KDELIBS_VER=3
USE_LDCONFIG= yes
MAN1= kmuddy.1
OPTIONS= SDL "Use SDL for sound output (required for MIDI)" off
.include <bsd.port.pre.mk>
.if defined(WITH_SDL)
CONFIGURE_ARGS+=--with-sdl
USE_SDL= mixer
.endif
post-patch:
@${SETENV} LANG=C TZ=UTC ${TOUCH} -t 200511301031.32 ${WRKSRC}/admin/libtool.m4.in
@${SETENV} LANG=C TZ=UTC ${TOUCH} -t 200510120853.48 ${WRKSRC}/Makefile.am
.include <bsd.port.post.mk>

3
net/kmuddy/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (kmuddy-0.8.tar.gz) = 59aa164db9bde9d9954f37c5adfd340b
SHA256 (kmuddy-0.8.tar.gz) = 7f65a3932696f84e11058b673fa3ec0f47d3f060191982438075a01c4d261265
SIZE (kmuddy-0.8.tar.gz) = 1058011

View File

@ -0,0 +1,7 @@
--- kmuddy/kmuddy.desktop.orig Sun Feb 25 18:40:54 2007
+++ kmuddy/kmuddy.desktop Sun Feb 25 18:41:07 2007
@@ -11,3 +11,4 @@
Terminal=0
Name=KMuddy
Name[de]=KMuddy
+Categories=Qt;KDE;Network;Games;

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

24
net/kmuddy/pkg-descr Normal file
View File

@ -0,0 +1,24 @@
KMuddy is a MUD client for KDE desktop environment.
Features:
MUD output displayer with ANSI color support,
MCCP v1/v2 (compression protocol), MSP (sound protocol),
multiple connections within one instance, configurable colors, short-cuts,
split screen when viewing output history, command history, connection profiles,
quick connect, auto-connect on startup, configurable login sequence,
multi-line input, word wrapping and indentation, aliases (with regex support),
triggers (with regex support), color triggers,
special-purpose triggers (sound, notification, ...), prompt-detection triggers,
gagging, test area for aliases and triggers, alias/trigger groups
profile settings, session transcript, speed-walking, action toolbar,
external scripting support, timers, macro keys, variables,
variable support in external scripts,
triggers that redirect text to another window,
remembering positions of those windows between sessions,
triggers hooked to variables (executed when value changes),
TAB-expansion of last words, MXP (extension protocol) partial support,
internal scripting, conditional triggers, Plug-in support, full color support,
rewrite triggers, status variables, support for gauges,
functions for string manipulation
WWW: http://www.kmuddy.com/

70
net/kmuddy/pkg-plist Normal file
View File

@ -0,0 +1,70 @@
bin/kmuddy
include/kmuddy/arith-exp.h
include/kmuddy/cactionbase.h
include/kmuddy/cactionmanager.h
include/kmuddy/calias.h
include/kmuddy/caliaslist.h
include/kmuddy/cansiparser.h
include/kmuddy/ccmdparser.h
include/kmuddy/ccmdprocessor.h
include/kmuddy/ccmdqueue.h
include/kmuddy/cconnectioninfo.h
include/kmuddy/cconnprefs.h
include/kmuddy/cconsole.h
include/kmuddy/cdownloader.h
include/kmuddy/cexpresolver.h
include/kmuddy/cgroup.h
include/kmuddy/cgrouplist.h
include/kmuddy/cinputline.h
include/kmuddy/cmacromanager.h
include/kmuddy/cmenumanager.h
include/kmuddy/cmsp.h
include/kmuddy/cnumberedchecklistitem.h
include/kmuddy/cnumberedlistitem.h
include/kmuddy/coutput.h
include/kmuddy/cplugin.h
include/kmuddy/cprofiles.h
include/kmuddy/cprompt.h
include/kmuddy/csaveablefield.h
include/kmuddy/csaveablelist.h
include/kmuddy/csoundplayer.h
include/kmuddy/cstatus.h
include/kmuddy/ctextchunk.h
include/kmuddy/cvalue.h
include/kmuddy/cvariable.h
include/kmuddy/cvariablelist.h
lib/kde3/kmuddyscriptingplugin.a
lib/kde3/kmuddyscriptingplugin.la
lib/kde3/kmuddyscriptingplugin.so
lib/kde3/kmuddystringsplugin.a
lib/kde3/kmuddystringsplugin.la
lib/kde3/kmuddystringsplugin.so
lib/libkmuddy.a
lib/libkmuddy.la
lib/libkmuddy.so
lib/libkmuddy.so.0
share/applnk/Games/kmuddy.desktop
share/doc/HTML/en/kmuddy/common
share/doc/HTML/en/kmuddy/index.cache.bz2
share/doc/HTML/en/kmuddy/index.docbook
share/icons/hicolor/16x16/actions/aliases.png
share/icons/hicolor/16x16/apps/kmuddy.png
share/icons/hicolor/32x32/apps/kmuddy.png
share/icons/locolor/16x16/apps/kmuddy.png
share/icons/locolor/32x32/apps/kmuddy.png
share/kmuddy/README
share/kmuddy/kmuddy-usock-client.pl
share/kmuddy/kmuddy-usock-test.pl
share/kmuddy/kmuddyvars.h
share/kmuddy/locktest.c
share/kmuddy/pre.c
share/kmuddy/testserver.cpp
share/kmuddy/tmpserver.pl
share/kmuddy/vartest.c
share/locale/es/LC_MESSAGES/kmuddy.mo
share/services/kmuddyscriptingplugin.desktop
share/services/kmuddystringsplugin.desktop
share/servicetypes/kmuddyplugin.desktop
@dirrm share/kmuddy
@dirrm share/doc/HTML/en/kmuddy
@dirrm include/kmuddy