Import of upclient.

This is the client program for the Server Uptimes project.
For more information on the Server Uptimes project visit their web site at:
 http://uptime.hexon.cx/

PR:		13272
Submitted by:	Kelly Yancey <kbyanc@posi.net>
This commit is contained in:
Chris Piazza 1999-08-28 19:27:20 +00:00
parent edf87e5017
commit 5e30dde42d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21067
8 changed files with 89 additions and 0 deletions

21
misc/upclient/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: upclient
# Version required: 3.04
# Date created: 20 Aug 1999
# Whom: Kelly Yancey <kbyanc@posi.net>
#
# $Id$
#
DISTNAME= upclient-3.04
CATEGORIES= misc
MASTER_SITES= ftp://uptime.hexon.cx/pub/
MAINTAINER= kbyanc@posi.net
ALL_TARGET= bsd
INSTALL_TARGET= bsd install CP=$(CP)
post-install:
${CAT} ${PKGMESSAGE} | ${SED} 's:/usr/local:${PREFIX}:g'
.include <bsd.port.mk>

1
misc/upclient/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (upclient-3.04.tar.gz) = 5a67b17ef0ddbd44fa668c81d8de0547

View File

@ -0,0 +1,30 @@
--- Makefile.orig Sat Apr 10 02:47:19 1999
+++ Makefile Fri Aug 20 14:51:05 1999
@@ -1,7 +1,7 @@
# Uptime Client Makefile
# Location of config file (for example /etc/upclient.conf)
-CONFIGFILE = upclient.conf
+CONFIGFILE = $(PREFIX)/etc/upclient.conf
################
@@ -29,10 +29,8 @@
upclient
bsd:
- $(MAKE) CC=gcc \
- LDFLAGS= \
- OBJECTS= \
- CFLAGS='-DPLAT_xxxBSD -DCONFIGFILE=\"$(CONFIGFILE)\"' \
+ $(MAKE) OBJECTS= \
+ CFLAGS='$(CFLAGS) -DPLAT_xxxBSD -DCONFIGFILE=\"$(CONFIGFILE)\"' \
upclient
solaris:
@@ -88,3 +86,5 @@
install: prepared-for-install
strip $(BINNAME)
chmod 755 $(BINNAME)
+ $(INSTALL) $(BINNAME) $(PREFIX)/bin
+ $(CP) upclient.conf $(PREFIX)/etc

View File

@ -0,0 +1,9 @@
--- upclient.conf.orig Fri Aug 20 11:22:32 1999
+++ upclient.conf Fri Aug 20 11:25:12 1999
@@ -3,5 +3,5 @@
HostID <HostID>
Login <Loginname>
Pass <Password>
-Interval 60
+Interval 550
UptimeServer uptime.hexon.cx

View File

@ -0,0 +1 @@
The Server Uptimes project client

7
misc/upclient/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
This is the client program for the Server Uptimes project.
For more information on the Server Uptimes project visit their web site at:
WWW: http://uptime.hexon.cx/
-Kelly
kbyanc@posi.net

18
misc/upclient/pkg-message Normal file
View File

@ -0,0 +1,18 @@
Before running the client for the first time, be sure to:
1. visit the Server Uptimes project web site and register yourself
(WWW: http://uptime.hexon.cx/register.html),
2. log in (WWW: http://uptime.hexon.cx/login)
3. Add your host (WWW: http://uptime.hexon.cx/login/cgi-bin/addhost.cgi)
Note that in order to send your uptime information to the uptime server,
you hosts need more-or-less full-time Internet access.
You will also need to edit /usr/local/etc/upclient.conf:
HostID is the ID you've received when you added your host
Login and pass are your login and password
Interval is the amount of time between each update.
Don't set this higher than 10 minutes, or else your host
won't appear in the list.

2
misc/upclient/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
bin/upclient
etc/upclient.conf