Update to version 1.0.3.

Make USE_GNOMELIBS optional. Add a patch that fixes a native library bug.
This commit is contained in:
Archie Cobbs 2002-08-19 05:10:00 +00:00
parent 169e14e0fc
commit 5189413ce3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64648
10 changed files with 83 additions and 19 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= sablevm
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= java
MASTER_SITES= http://unc.dl.sourceforge.net/sablevm/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@ -28,11 +28,39 @@ LIBTOOLFILES= ${SABLEVMDIR}/configure ${NATIVEDIR}/configure
USE_GMAKE= yes
INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
# Uncomment to force gnome dependency
#USE_GNOMELIBS= yes
# Directories for the three SableVM source components
SABLEVMDIR= ${PORTNAME}-${PORTVERSION}
NATIVEDIR= ${PORTNAME}-native-library-${PORTVERSION}
CLASSESDIR= ${PORTNAME}-class-library-${PORTVERSION}
# Conditionally compile the gnome-dependent stuff
.if !defined(USE_GNOMELIBS) && !exists(${X11BASE}/libart_lgpl/art_misc.h)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa ${PATCHDIR}/extra-patch-ab
pre-fetch:
@${ECHO} ''
@${ECHO} '***' ' ' NOTICE
@${ECHO} '***'
@${ECHO} '***' You do not seem to have the Gnome libraries installed.
@${ECHO} '***' Therefore, SableVM will be built without graphics
@${ECHO} '***' support. If you would like to install the Gnome
@${ECHO} '***' libraries for include graphics support, hit Control-C
@${ECHO} '***' now and type \'make USE_GNOMELIBS=yes\'.
@${ECHO} ''
@sleep 3
.endif
# Repair make dependency damage caused by patching 'configure.ac' files
post-patch:
@for dir in ${SABLEVMDIR}; do \
for file in aclocal.m4 configure Makefile.in Makefile; do \
${ECHO} ${TOUCH} ${WRKDIR}/$${dir}/$${file}; \
touch ${WRKDIR}/$${dir}/$${file}; \
done; \
done
pre-configure:
@echo "===> ${NATIVEDIR}"
@( cd ${.CURDIR} && ${MAKE} do-configure \

View File

@ -1,3 +1,3 @@
MD5 (sablevm-1.0.2.tar.gz) = 6e71b859a086c1076262c59b806ff845
MD5 (sablevm-class-library-1.0.2.tar.gz) = 092c6c0f997e3a05c0cd980db1a49d90
MD5 (sablevm-native-library-1.0.2.tar.gz) = ec91122450b0f025212de5926205211d
MD5 (sablevm-1.0.3.tar.gz) = 5e556b93e8fce7c4fb5803447e9ce505
MD5 (sablevm-class-library-1.0.3.tar.gz) = 73875d2e43e7525bc12ce6e396046275
MD5 (sablevm-native-library-1.0.3.tar.gz) = 49ab529f7680cfcc38accc41d9a9868a

View File

@ -0,0 +1,13 @@
diff -ur work.orig/sablevm-native-library-1.0.3/src/Makefile.in work/sablevm-native-library-1.0.3/src/Makefile.in
--- work.orig/sablevm-native-library-1.0.3/src/Makefile.in Wed Aug 14 22:32:02 2002
+++ work/sablevm-native-library-1.0.3/src/Makefile.in Sun Aug 18 10:24:12 2002
@@ -94,8 +94,7 @@
java-io \
java-lang \
java-net \
- java-util \
- gnu-java-awt-peer-gtk
+ java-util
subdir = src
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View File

@ -0,0 +1,10 @@
diff -ur work.orig/sablevm-native-library-1.0.3/src/Makefile.am work/sablevm-native-library-1.0.3/src/Makefile.am
--- work.orig/sablevm-native-library-1.0.3/src/Makefile.am Sun Jul 28 17:14:15 2002
+++ work/sablevm-native-library-1.0.3/src/Makefile.am Sun Aug 18 17:26:09 2002
@@ -44,5 +44,4 @@
java-io \
java-lang \
java-net \
- java-util \
- gnu-java-awt-peer-gtk
+ java-util

View File

@ -1,6 +1,6 @@
diff -ur work.orig/sablevm-1.0.2/configure work/sablevm-1.0.2/configure
--- work.orig/sablevm-1.0.2/configure Wed Aug 14 22:34:00 2002
+++ work/sablevm-1.0.2/configure Thu Aug 15 14:56:41 2002
diff -ur work.orig/sablevm-1.0.3/configure work/sablevm-1.0.3/configure
--- work.orig/sablevm-1.0.3/configure Wed Aug 14 22:34:00 2002
+++ work/sablevm-1.0.3/configure Sat Aug 17 21:14:52 2002
@@ -7747,6 +7747,9 @@

View File

@ -1,6 +1,6 @@
diff -ur work.orig/sablevm-1.0.2/configure.ac work/sablevm-1.0.2/configure.ac
--- work.orig/sablevm-1.0.2/configure.ac Wed Aug 14 22:29:54 2002
+++ work/sablevm-1.0.2/configure.ac Thu Aug 15 14:54:29 2002
diff -ur work.orig/sablevm-1.0.3/configure.ac work/sablevm-1.0.3/configure.ac
--- work.orig/sablevm-1.0.3/configure.ac Wed Aug 14 22:29:54 2002
+++ work/sablevm-1.0.3/configure.ac Sat Aug 17 21:14:51 2002
@@ -114,12 +114,15 @@
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL

View File

@ -1,6 +1,6 @@
diff -ur work.orig/sablevm-1.0.2/src/libsablevm/Makefile.am work/sablevm-1.0.2/src/libsablevm/Makefile.am
--- work.orig/sablevm-1.0.2/src/libsablevm/Makefile.am Sun Aug 11 14:33:05 2002
+++ work/sablevm-1.0.2/src/libsablevm/Makefile.am Thu Aug 15 14:54:29 2002
diff -ur work.orig/sablevm-1.0.3/src/libsablevm/Makefile.am work/sablevm-1.0.3/src/libsablevm/Makefile.am
--- work.orig/sablevm-1.0.3/src/libsablevm/Makefile.am Sun Aug 11 14:33:05 2002
+++ work/sablevm-1.0.3/src/libsablevm/Makefile.am Sat Aug 17 21:14:51 2002
@@ -306,7 +306,7 @@
rm -f util.c
rm -f vm_args.c

View File

@ -1,6 +1,6 @@
diff -ur work.orig/sablevm-1.0.2/src/libsablevm/Makefile.in work/sablevm-1.0.2/src/libsablevm/Makefile.in
--- work.orig/sablevm-1.0.2/src/libsablevm/Makefile.in Wed Aug 14 22:34:07 2002
+++ work/sablevm-1.0.2/src/libsablevm/Makefile.in Thu Aug 15 14:56:32 2002
diff -ur work.orig/sablevm-1.0.3/src/libsablevm/Makefile.in work/sablevm-1.0.3/src/libsablevm/Makefile.in
--- work.orig/sablevm-1.0.3/src/libsablevm/Makefile.in Wed Aug 14 22:34:07 2002
+++ work/sablevm-1.0.3/src/libsablevm/Makefile.in Sat Aug 17 21:14:51 2002
@@ -245,7 +245,7 @@
vm_args.m4.c

View File

@ -1,6 +1,6 @@
diff -ur work.orig/sablevm-1.0.2/src/libsablevm/libsablevm.c work/sablevm-1.0.2/src/libsablevm/libsablevm.c
--- work.orig/sablevm-1.0.2/src/libsablevm/libsablevm.c Sun Aug 11 14:33:05 2002
+++ work/sablevm-1.0.2/src/libsablevm/libsablevm.c Thu Aug 15 15:09:36 2002
diff -ur work.orig/sablevm-1.0.3/src/libsablevm/libsablevm.c work/sablevm-1.0.3/src/libsablevm/libsablevm.c
--- work.orig/sablevm-1.0.3/src/libsablevm/libsablevm.c Sun Aug 11 14:33:05 2002
+++ work/sablevm-1.0.3/src/libsablevm/libsablevm.c Sat Aug 17 21:14:51 2002
@@ -5,6 +5,9 @@
* modification of SableVM. *
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * */

View File

@ -0,0 +1,13 @@
diff -ur work.orig/sablevm-1.0.3/src/libsablevm/libsablevm.c work/sablevm-1.0.3/src/libsablevm/libsablevm.c
--- work.orig/sablevm-1.0.3/src/libsablevm/java_lang_Runtime.c Tue Aug 6 03:27:22 2002
+++ work/sablevm-1.0.3/src/libsablevm/java_lang_Runtime.c Sun Aug 18 21:56:25 2002
@@ -254,6 +254,9 @@
(*(class_loader_info->native_library_list_tail))->name = filename;
(*(class_loader_info->native_library_list_tail))->handle = handle;
+ class_loader_info->native_library_list_tail =
+ &(*(class_loader_info->native_library_list_tail))->next;
+
result = 1;
end: