Upgrade to 0.90
Noticed by: Jim Dutton <jimd@dutton3.it.siu.edu>
This commit is contained in:
parent
a1ea5250fa
commit
50bea79525
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18853
@ -1,25 +1,35 @@
|
||||
# New ports collection makefile for: sentry
|
||||
# Version required: 0.61
|
||||
# Version required: 0.90
|
||||
# Date created: 3 January 1998
|
||||
# Whom: chris@still.whet.org
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1999/01/20 20:49:45 max Exp $
|
||||
# $Id: Makefile,v 1.3 1999/04/19 19:49:32 mharo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= portsentry-0.61
|
||||
DISTNAME= portsentry-0.90
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.psionic.com/tools/
|
||||
|
||||
MAINTAINER= chris@still.whet.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/sentry_beta
|
||||
ALL_TARGET= bsd
|
||||
ALL_TARGET= freebsd
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/sentry
|
||||
${INSTALL_DATA} ${WRKSRC}/README.install ${WRKSRC}/README.methods \
|
||||
${PREFIX}/share/doc/sentry
|
||||
post-patch:
|
||||
@/usr/bin/perl -pi -e 's,__PREFIX__,${PREFIX},g' ${WRKSRC}/portsentry.conf
|
||||
@/usr/bin/perl -pi -e 's,__PREFIX__,${PREFIX},g' ${WRKSRC}/portsentry_config.h
|
||||
|
||||
do-install:
|
||||
.if !exists($(PREFIX)/etc/portsentry.conf)
|
||||
${INSTALL_DATA} ${WRKSRC}/portsentry.conf ${PREFIX}/etc
|
||||
.endif
|
||||
${INSTALL_DATA} ${WRKSRC}/portsentry.conf ${PREFIX}/etc/portsentry.conf.default
|
||||
${INSTALL_DATA} ${WRKSRC}/portsentry.ignore ${PREFIX}/etc
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/portsentry ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/portsentry
|
||||
${INSTALL_DATA} ${WRKSRC}/README.install ${WRKSRC}/README.methods \
|
||||
${PREFIX}/share/doc/portsentry
|
||||
.endif
|
||||
@${CAT} ${PKGDIR}/MESSAGE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (portsentry-0.61.tar.gz) = 57bf7e0caf99188018ef1ab6131faf4b
|
||||
MD5 (portsentry-0.90.tar.gz) = 80eead64b3d6efb10748b80ecec0f54a
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig Thu May 28 22:54:11 1998
|
||||
+++ Makefile Sun Apr 11 20:09:52 1999
|
||||
@@ -20,18 +20,19 @@
|
||||
--- Makefile.orig Sun May 16 21:55:26 1999
|
||||
+++ Makefile Sun May 16 21:55:46 1999
|
||||
@@ -13,12 +13,13 @@
|
||||
#
|
||||
|
||||
# Generic compiler
|
||||
@ -10,45 +10,9 @@
|
||||
#CC = gcc
|
||||
|
||||
# Normal systems flags
|
||||
-CFLAGS = -O
|
||||
+CFLAGS ?= -O
|
||||
-CFLAGS = -O -Wall
|
||||
+CFLAGS ?= -O -Wall
|
||||
+CFLAGS += -DPREFIX=\"${PREFIX}\"
|
||||
|
||||
# Debug mode for sentry
|
||||
#CFLAGS = -Wall -g -DDEBUG
|
||||
|
||||
|
||||
-INSTALLDIR = /usr/local/abacus
|
||||
+INSTALLDIR = ${PREFIX}
|
||||
|
||||
|
||||
all:
|
||||
@@ -54,21 +55,16 @@
|
||||
/bin/rmdir $(INSTALLDIR)
|
||||
|
||||
install:
|
||||
- @echo "Creating abacus directory $(INSTALLDIR)"
|
||||
- @if [ ! -d $(INSTALLDIR) ]; then /bin/mkdir $(INSTALLDIR); fi
|
||||
- @echo "Setting directory permissions"
|
||||
- chmod 700 $(INSTALLDIR)
|
||||
- @echo "Copying files"
|
||||
- cp ./sentry.conf $(INSTALLDIR)
|
||||
- cp ./sentry.ignore $(INSTALLDIR)
|
||||
- cp ./sentry $(INSTALLDIR)
|
||||
+ cp ./sentry.conf $(INSTALLDIR)/etc
|
||||
+ cp ./sentry.ignore $(INSTALLDIR)/etc
|
||||
+ cp ./sentry $(INSTALLDIR)/bin
|
||||
@echo "Setting permissions"
|
||||
- chmod 600 $(INSTALLDIR)/sentry.ignore
|
||||
- chmod 600 $(INSTALLDIR)/sentry.conf
|
||||
- chmod 700 $(INSTALLDIR)/sentry
|
||||
+ chmod 600 $(INSTALLDIR)/etc/sentry.ignore
|
||||
+ chmod 600 $(INSTALLDIR)/etc/sentry.conf
|
||||
+ chmod 700 $(INSTALLDIR)/bin/sentry
|
||||
@echo ""
|
||||
@echo ""
|
||||
- @echo "Edit $(INSTALLDIR)/sentry.conf and change"
|
||||
+ @echo "Edit $(INSTALLDIR)/etc/sentry.conf and change"
|
||||
@echo "your settings if you haven't already. (route, etc)"
|
||||
@echo ""
|
||||
@echo ""
|
||||
# Debug mode for portsentry
|
||||
#CFLAGS = -Wall -g -DNODAEMON -DDEBUG
|
||||
|
@ -1,17 +1,17 @@
|
||||
--- sentry.conf.orig Sat Dec 19 11:06:01 1998
|
||||
+++ sentry.conf Sat Dec 19 11:06:22 1998
|
||||
--- portsentry.conf.orig Sun May 16 21:50:55 1999
|
||||
+++ portsentry.conf Sun May 16 21:51:27 1999
|
||||
@@ -80,11 +80,11 @@
|
||||
######################
|
||||
#
|
||||
# Hosts to ignore
|
||||
-IGNORE_FILE="/usr/local/abacus/sentry.ignore"
|
||||
+IGNORE_FILE="/usr/local/etc/sentry.ignore"
|
||||
-IGNORE_FILE="/usr/local/psionic/portsentry/portsentry.ignore"
|
||||
+IGNORE_FILE="__PREFIX__/etc/portsentry.ignore"
|
||||
# Hosts that have been denied (running history)
|
||||
-HISTORY_FILE="/usr/local/abacus/sentry.history"
|
||||
+HISTORY_FILE="/usr/local/etc/sentry.history"
|
||||
-HISTORY_FILE="/usr/local/psionic/portsentry/portsentry.history"
|
||||
+HISTORY_FILE="__PREFIX__/etc/portsentry.history"
|
||||
# Hosts that have been denied this session only (temporary until next restart)
|
||||
-BLOCKED_FILE="/usr/local/abacus/sentry.blocked"
|
||||
+BLOCKED_FILE="/usr/local/etc/sentry.blocked"
|
||||
-BLOCKED_FILE="/usr/local/psionic/portsentry/portsentry.blocked"
|
||||
+BLOCKED_FILE="__PREFIX__/etc/portsentry.blocked"
|
||||
|
||||
###################
|
||||
# Response Options#
|
||||
|
@ -1,16 +1,18 @@
|
||||
--- sentry_config.h.orig Thu May 28 22:24:11 1998
|
||||
+++ sentry_config.h Thu Jan 21 06:05:33 1999
|
||||
@@ -32,7 +32,12 @@
|
||||
--- portsentry_config.h.orig Sun May 16 21:52:00 1999
|
||||
+++ portsentry_config.h Sun May 16 21:52:54 1999
|
||||
@@ -29,9 +29,14 @@
|
||||
/************************************************************************/
|
||||
|
||||
|
||||
/* These are probably ok. Be sure you change the Makefile if you */
|
||||
/* change the path */
|
||||
-#define CONFIG_FILE "/usr/local/abacus/sentry.conf"
|
||||
+/* Installation prefix */
|
||||
+#ifndef PREFIX
|
||||
+#define PREFIX "/usr/local"
|
||||
+#endif
|
||||
+
|
||||
+#define CONFIG_FILE PREFIX"/etc/sentry.conf"
|
||||
/* These are probably ok. Be sure you change the Makefile if you */
|
||||
/* change the path */
|
||||
-#define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf"
|
||||
+#define CONFIG_FILE PREFIX"/etc/portsentry.conf"
|
||||
|
||||
/* The location of Wietse Venema's TCP Wrapper hosts.deny file */
|
||||
#define WRAPPER_HOSTS_DENY "/etc/hosts.deny"
|
||||
|
@ -1,6 +1,7 @@
|
||||
bin/sentry
|
||||
etc/sentry.conf
|
||||
etc/sentry.ignore
|
||||
share/doc/sentry/README.install
|
||||
share/doc/sentry/README.methods
|
||||
@dirrm share/doc/sentry
|
||||
bin/portsentry
|
||||
etc/portsentry.conf.default
|
||||
@exec if [ ! -f %D/etc/portsentry.conf ] ; then cp -p %D/%F %B/portsentry.conf; fi
|
||||
etc/portsentry.ignore
|
||||
share/doc/portsentry/README.install
|
||||
share/doc/portsentry/README.methods
|
||||
@dirrm share/doc/portsentry
|
||||
|
Loading…
Reference in New Issue
Block a user