Upgrade to version 0.44.0

This commit is contained in:
Boris Popov 2000-07-18 04:56:46 +00:00
parent 58b7b9d5c0
commit 41fa24ec09
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30766
10 changed files with 142 additions and 86 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= nut
PORTVERSION= 0.43.1
PORTVERSION= 0.44.0
CATEGORIES= sysutils
MASTER_SITES= http://www.exploits.org/nut/release/
@ -18,7 +18,10 @@ LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-uid=65534 --with-gid=68
--with-cgipath=${PREFIX}/share/nut/cgi \
--with-modelpath=${PREFIX}/sbin \
--with-uid=65534 --with-gid=68
ALL_TARGET= all
PLIST= ${WRKDIR}/PLIST.DYN
@ -51,7 +54,11 @@ post-install:
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/upsd.sh.sample
.if !defined(NOPORTDOCS)
@if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
${INSTALL_DATA} ${WRKSRC}/docs/* ${NDOCDIR}
@if ! [ -d ${NDOCDIR}/cables ]; then ${MKDIR} ${NDOCDIR}/cables; fi
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${NDOCDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/Changes.trust ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/QUICKSTART ${NDOCDIR}
.endif

View File

@ -1 +1 @@
MD5 (nut-0.43.1.tar.gz) = 9f9ba2843065b6b8002558cd5dc779de
MD5 (nut-0.44.0.tar.gz) = 98314d5eb66db0e0eb367623cff16e56

View File

@ -1,30 +1,38 @@
diff -ru ../431/clients/Makefile.in ./clients/Makefile.in
--- ../431/clients/Makefile.in Mon Feb 14 09:39:16 2000
+++ ./clients/Makefile.in Mon Mar 6 17:29:46 2000
@@ -57,10 +57,10 @@
distclean: clean
diff -ur ../440/Makefile.in ./Makefile.in
--- ../440/Makefile.in Mon Jun 12 06:48:07 2000
+++ ./Makefile.in Tue Jul 18 11:51:25 2000
@@ -5,7 +5,7 @@
BASEPATH = $(INSTALLROOT)@prefix@
CONFPATH = $(INSTALLROOT)@sysconfdir@
CGIPATH = $(INSTALLROOT)@CGIPATH@
-INSTALLDIRS=$(CONFPATH) $(CGIPATH) $(MODELPATH) $(BASEPATH)/bin $(BASEPATH)/misc
+INSTALLDIRS=$(CONFPATH) $(CGIPATH) $(MODELPATH) $(BASEPATH)/bin
STATEPATH = $(INSTALLROOT)@STATEPATH@
SUBDIRS = common models server clients
diff -ur ../440/clients/Makefile.in ./clients/Makefile.in
--- ../440/clients/Makefile.in Fri Jul 14 05:55:41 2000
+++ ./clients/Makefile.in Mon Jul 17 17:48:29 2000
@@ -57,7 +57,7 @@
install: all
- $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/sbin
@for f in $(PROGS) ; do \
- $(INSTALLCMD) -m $(INSTALLMODE) $$f $(BASEPATH)/bin; \
+ $(INSTALLCMD) -m $(INSTALLMODE) $$f $(BASEPATH)/sbin; \
done
install-cgi: cgi
- $(INSTALLCMD) -m $(INSTALLMODE) $(CGIPROGS) $(BASEPATH)/cgi-bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(CGIPROGS) $(BASEPATH)/share/nut/cgi
install-misc: upsfetch.o
$(INSTALLCMD) upsfetch.[oh] $(BASEPATH)/misc
diff -ru ../431/conf/Makefile.in ./conf/Makefile.in
--- ../431/conf/Makefile.in Mon Feb 14 09:08:01 2000
+++ ./conf/Makefile.in Mon Mar 6 17:30:39 2000
@@ -12,17 +12,9 @@
diff -ur ../440/conf/Makefile.in ./conf/Makefile.in
--- ../440/conf/Makefile.in Mon May 8 04:17:20 2000
+++ ./conf/Makefile.in Mon Jul 17 17:49:43 2000
@@ -13,17 +13,9 @@
install:
@for f in $(SECFILES) ; do \
- if [ -f $(CONFPATH)/$$f ]; then \
- echo "Preserving existing config file: $$f"; \
- else \
- $(INSTALLCMD) -m 0600 $$f $(BASEPATH)/etc; \
- $(INSTALLCMD) -m 0600 $$f $(CONFPATH); \
- fi; \
+ $(INSTALLCMD) -m 0600 $$f $(CONFPATH)/$$f.sample; \
done
@ -33,25 +41,31 @@ diff -ru ../431/conf/Makefile.in ./conf/Makefile.in
- if [ -f $(CONFPATH)/$$f ]; then \
- echo "Preserving existing config file: $$f"; \
- else \
- $(INSTALLCMD) -m 0644 $$f $(BASEPATH)/etc; \
- $(INSTALLCMD) -m 0644 $$f $(CONFPATH); \
- fi; \
+ $(INSTALLCMD) -m 0644 $$f $(CONFPATH)/$$f.sample; \
done
diff -ru ../431/models/Makefile.in ./models/Makefile.in
--- ../431/models/Makefile.in Fri Feb 11 03:14:25 2000
+++ ./models/Makefile.in Mon Mar 6 17:29:46 2000
@@ -36,4 +36,4 @@
distclean: clean
diff -ur ../440/models/Makefile.in ./models/Makefile.in
--- ../440/models/Makefile.in Fri Jul 14 05:27:27 2000
+++ ./models/Makefile.in Tue Jul 18 10:59:01 2000
@@ -20,9 +20,7 @@
# in the future ala the Linux "make config" process...
$(PROGS): upscommon.o ../include/shared.h ../common/common.o
-
-.c:
- $(CC) $(CFLAGS) -o $* $*.c upscommon.o ../common/common.o
+ $(CC) $(CFLAGS) -o $* $*.c upscommon.o @SERLIBS@ ../common/common.o
#
# Housekeeping stuff
diff -ur ../440/server/Makefile.in ./server/Makefile.in
--- ../440/server/Makefile.in Fri Jul 14 05:30:40 2000
+++ ./server/Makefile.in Mon Jul 17 17:51:19 2000
@@ -24,5 +24,5 @@
install: all
- $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/sbin
diff -ru ../431/server/Makefile.in ./server/Makefile.in
--- ../431/server/Makefile.in Fri Feb 11 03:18:22 2000
+++ ./server/Makefile.in Mon Mar 6 17:29:46 2000
@@ -22,4 +22,4 @@
distclean: clean
install: all
- $(INSTALLCMD) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) $(PROGS) $(BASEPATH)/sbin
@for f in $(PROGS) ; do \
- $(INSTALLCMD) $$f $(BASEPATH)/bin; \
+ $(INSTALLCMD) $$f $(BASEPATH)/sbin; \
done

View File

@ -1,9 +1,13 @@
sbin/apcsmart
sbin/genericups
sbin/optiups
sbin/bestfort
sbin/bestups
sbin/ups-trust425+625
sbin/fentonups
sbin/genericups
sbin/ipt-anzen
sbin/mustekups
sbin/optiups
sbin/ups-trust425+625
sbin/victronups
sbin/upsc
sbin/upscmd
sbin/upslog
@ -17,6 +21,4 @@ etc/nut/upsd.conf.sample
etc/nut/upsmon.conf.sample
etc/nut/upsset.passwd.sample
etc/rc.d/upsd.sh.sample
@dirrm cgi-bin
@dirrm etc/nut
@dirrm misc

View File

@ -1,11 +1,14 @@
share/doc/nut/Changes.trust
share/doc/nut/FAQ
share/doc/nut/access.txt
share/doc/nut/big-servers.txt
share/doc/nut/commands.txt
share/doc/nut/configure.txt
share/doc/nut/data-room.txt
share/doc/nut/generic-ups.txt
share/doc/nut/new-modules.txt
share/doc/nut/pager.txt
share/doc/nut/powercom.txt
share/doc/nut/protocol.txt
share/doc/nut/shutdown.txt
share/doc/nut/tips.txt
@ -13,4 +16,6 @@ share/doc/nut/todo.txt
share/doc/nut/ups-trust425+625.txt
share/doc/nut/README
share/doc/nut/QUICKSTART
share/doc/nut/cables/victron.txt
@dirrm share/doc/nut/cables
@dirrm share/doc/nut

View File

@ -6,7 +6,7 @@
#
PORTNAME= nut
PORTVERSION= 0.43.1
PORTVERSION= 0.44.0
CATEGORIES= sysutils
MASTER_SITES= http://www.exploits.org/nut/release/
@ -18,7 +18,10 @@ LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-uid=65534 --with-gid=68
--with-cgipath=${PREFIX}/share/nut/cgi \
--with-modelpath=${PREFIX}/sbin \
--with-uid=65534 --with-gid=68
ALL_TARGET= all
PLIST= ${WRKDIR}/PLIST.DYN
@ -51,7 +54,11 @@ post-install:
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/upsd.sh.sample
.if !defined(NOPORTDOCS)
@if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
${INSTALL_DATA} ${WRKSRC}/docs/* ${NDOCDIR}
@if ! [ -d ${NDOCDIR}/cables ]; then ${MKDIR} ${NDOCDIR}/cables; fi
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${NDOCDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/Changes.trust ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/QUICKSTART ${NDOCDIR}
.endif

View File

@ -1 +1 @@
MD5 (nut-0.43.1.tar.gz) = 9f9ba2843065b6b8002558cd5dc779de
MD5 (nut-0.44.0.tar.gz) = 98314d5eb66db0e0eb367623cff16e56

View File

@ -1,30 +1,38 @@
diff -ru ../431/clients/Makefile.in ./clients/Makefile.in
--- ../431/clients/Makefile.in Mon Feb 14 09:39:16 2000
+++ ./clients/Makefile.in Mon Mar 6 17:29:46 2000
@@ -57,10 +57,10 @@
distclean: clean
diff -ur ../440/Makefile.in ./Makefile.in
--- ../440/Makefile.in Mon Jun 12 06:48:07 2000
+++ ./Makefile.in Tue Jul 18 11:51:25 2000
@@ -5,7 +5,7 @@
BASEPATH = $(INSTALLROOT)@prefix@
CONFPATH = $(INSTALLROOT)@sysconfdir@
CGIPATH = $(INSTALLROOT)@CGIPATH@
-INSTALLDIRS=$(CONFPATH) $(CGIPATH) $(MODELPATH) $(BASEPATH)/bin $(BASEPATH)/misc
+INSTALLDIRS=$(CONFPATH) $(CGIPATH) $(MODELPATH) $(BASEPATH)/bin
STATEPATH = $(INSTALLROOT)@STATEPATH@
SUBDIRS = common models server clients
diff -ur ../440/clients/Makefile.in ./clients/Makefile.in
--- ../440/clients/Makefile.in Fri Jul 14 05:55:41 2000
+++ ./clients/Makefile.in Mon Jul 17 17:48:29 2000
@@ -57,7 +57,7 @@
install: all
- $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/sbin
@for f in $(PROGS) ; do \
- $(INSTALLCMD) -m $(INSTALLMODE) $$f $(BASEPATH)/bin; \
+ $(INSTALLCMD) -m $(INSTALLMODE) $$f $(BASEPATH)/sbin; \
done
install-cgi: cgi
- $(INSTALLCMD) -m $(INSTALLMODE) $(CGIPROGS) $(BASEPATH)/cgi-bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(CGIPROGS) $(BASEPATH)/share/nut/cgi
install-misc: upsfetch.o
$(INSTALLCMD) upsfetch.[oh] $(BASEPATH)/misc
diff -ru ../431/conf/Makefile.in ./conf/Makefile.in
--- ../431/conf/Makefile.in Mon Feb 14 09:08:01 2000
+++ ./conf/Makefile.in Mon Mar 6 17:30:39 2000
@@ -12,17 +12,9 @@
diff -ur ../440/conf/Makefile.in ./conf/Makefile.in
--- ../440/conf/Makefile.in Mon May 8 04:17:20 2000
+++ ./conf/Makefile.in Mon Jul 17 17:49:43 2000
@@ -13,17 +13,9 @@
install:
@for f in $(SECFILES) ; do \
- if [ -f $(CONFPATH)/$$f ]; then \
- echo "Preserving existing config file: $$f"; \
- else \
- $(INSTALLCMD) -m 0600 $$f $(BASEPATH)/etc; \
- $(INSTALLCMD) -m 0600 $$f $(CONFPATH); \
- fi; \
+ $(INSTALLCMD) -m 0600 $$f $(CONFPATH)/$$f.sample; \
done
@ -33,25 +41,31 @@ diff -ru ../431/conf/Makefile.in ./conf/Makefile.in
- if [ -f $(CONFPATH)/$$f ]; then \
- echo "Preserving existing config file: $$f"; \
- else \
- $(INSTALLCMD) -m 0644 $$f $(BASEPATH)/etc; \
- $(INSTALLCMD) -m 0644 $$f $(CONFPATH); \
- fi; \
+ $(INSTALLCMD) -m 0644 $$f $(CONFPATH)/$$f.sample; \
done
diff -ru ../431/models/Makefile.in ./models/Makefile.in
--- ../431/models/Makefile.in Fri Feb 11 03:14:25 2000
+++ ./models/Makefile.in Mon Mar 6 17:29:46 2000
@@ -36,4 +36,4 @@
distclean: clean
diff -ur ../440/models/Makefile.in ./models/Makefile.in
--- ../440/models/Makefile.in Fri Jul 14 05:27:27 2000
+++ ./models/Makefile.in Tue Jul 18 10:59:01 2000
@@ -20,9 +20,7 @@
# in the future ala the Linux "make config" process...
$(PROGS): upscommon.o ../include/shared.h ../common/common.o
-
-.c:
- $(CC) $(CFLAGS) -o $* $*.c upscommon.o ../common/common.o
+ $(CC) $(CFLAGS) -o $* $*.c upscommon.o @SERLIBS@ ../common/common.o
#
# Housekeeping stuff
diff -ur ../440/server/Makefile.in ./server/Makefile.in
--- ../440/server/Makefile.in Fri Jul 14 05:30:40 2000
+++ ./server/Makefile.in Mon Jul 17 17:51:19 2000
@@ -24,5 +24,5 @@
install: all
- $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) -m $(INSTALLMODE) $(PROGS) $(BASEPATH)/sbin
diff -ru ../431/server/Makefile.in ./server/Makefile.in
--- ../431/server/Makefile.in Fri Feb 11 03:18:22 2000
+++ ./server/Makefile.in Mon Mar 6 17:29:46 2000
@@ -22,4 +22,4 @@
distclean: clean
install: all
- $(INSTALLCMD) $(PROGS) $(BASEPATH)/bin
+ $(INSTALLCMD) $(PROGS) $(BASEPATH)/sbin
@for f in $(PROGS) ; do \
- $(INSTALLCMD) $$f $(BASEPATH)/bin; \
+ $(INSTALLCMD) $$f $(BASEPATH)/sbin; \
done

View File

@ -1,9 +1,13 @@
sbin/apcsmart
sbin/genericups
sbin/optiups
sbin/bestfort
sbin/bestups
sbin/ups-trust425+625
sbin/fentonups
sbin/genericups
sbin/ipt-anzen
sbin/mustekups
sbin/optiups
sbin/ups-trust425+625
sbin/victronups
sbin/upsc
sbin/upscmd
sbin/upslog
@ -17,6 +21,4 @@ etc/nut/upsd.conf.sample
etc/nut/upsmon.conf.sample
etc/nut/upsset.passwd.sample
etc/rc.d/upsd.sh.sample
@dirrm cgi-bin
@dirrm etc/nut
@dirrm misc

View File

@ -1,11 +1,14 @@
share/doc/nut/Changes.trust
share/doc/nut/FAQ
share/doc/nut/access.txt
share/doc/nut/big-servers.txt
share/doc/nut/commands.txt
share/doc/nut/configure.txt
share/doc/nut/data-room.txt
share/doc/nut/generic-ups.txt
share/doc/nut/new-modules.txt
share/doc/nut/pager.txt
share/doc/nut/powercom.txt
share/doc/nut/protocol.txt
share/doc/nut/shutdown.txt
share/doc/nut/tips.txt
@ -13,4 +16,6 @@ share/doc/nut/todo.txt
share/doc/nut/ups-trust425+625.txt
share/doc/nut/README
share/doc/nut/QUICKSTART
share/doc/nut/cables/victron.txt
@dirrm share/doc/nut/cables
@dirrm share/doc/nut