diff --git a/graphics/jogamp-jogl/Makefile b/graphics/jogamp-jogl/Makefile
index fbb4c15b0d82..2d4274747ce6 100644
--- a/graphics/jogamp-jogl/Makefile
+++ b/graphics/jogamp-jogl/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= jogamp-jogl
-PORTVERSION= 2.1.5
-PORTREVISION= 2
+PORTVERSION= 2.2.4
CATEGORIES= graphics devel java
-MASTER_SITES= http://jogamp.org/deployment/jogamp-current/archive/Sources/
+MASTER_SITES= http://jogamp.org/deployment/jogamp-current/archive/Sources/ \
+ http://jogamp.org/deployment/v${PORTVERSION}/archive/Sources/
DISTFILES= jogl-v${PORTVERSION}.tar.7z \
gluegen-v${PORTVERSION}.tar.7z
@@ -42,6 +42,8 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|g' \
${BUILD_WRKSRC}/build-common.xml
+ ${REINPLACE_CMD} -e '/name="all"/s|,test.compile||g' \
+ ${BUILD_WRKSRC}/build.xml
pre-build:
@(cd ${WRKDIR}/gluegen/make; \
diff --git a/graphics/jogamp-jogl/distinfo b/graphics/jogamp-jogl/distinfo
index c82b006d0bd4..790d3d0fce54 100644
--- a/graphics/jogamp-jogl/distinfo
+++ b/graphics/jogamp-jogl/distinfo
@@ -1,4 +1,4 @@
-SHA256 (jogl-v2.1.5.tar.7z) = e64474c28e4dd64f2a926ef2c8a645fe4de0ca9db482f939b1b84ba624d42bd5
-SIZE (jogl-v2.1.5.tar.7z) = 21513866
-SHA256 (gluegen-v2.1.5.tar.7z) = 9ca3c0961f790e778bf4453a6d676e6cfa72a0ca9cd461bd65710777bc3c9247
-SIZE (gluegen-v2.1.5.tar.7z) = 38641669
+SHA256 (jogl-v2.2.4.tar.7z) = 39d53fc4c4c3f8e3a5287646bc10457cfaa6fcc88f07c0b0c7817a95cb1f282b
+SIZE (jogl-v2.2.4.tar.7z) = 33454202
+SHA256 (gluegen-v2.2.4.tar.7z) = 6ad7b35f7c8fc81ec57d986f54b93c5c93127cd6c2b0efc2fb3950022feb15da
+SIZE (gluegen-v2.2.4.tar.7z) = 39334025
diff --git a/graphics/jogamp-jogl/files/patch-gluegen2 b/graphics/jogamp-jogl/files/patch-gluegen2
index fd05d8d44b6d..1368dcb0ec1f 100644
--- a/graphics/jogamp-jogl/files/patch-gluegen2
+++ b/graphics/jogamp-jogl/files/patch-gluegen2
@@ -1,6 +1,6 @@
---- gluegen/make/build.xml.orig 2014-03-10 13:56:04.000000000 +0000
-+++ gluegen/make/build.xml 2014-05-08 18:55:36.726179257 +0000
-@@ -439,7 +439,7 @@
+--- gluegen/make/build.xml.orig 2014-10-10 13:20:51 UTC
++++ gluegen/make/build.xml
+@@ -408,7 +408,7 @@
@@ -9,44 +9,44 @@
-@@ -633,14 +633,14 @@
+@@ -604,14 +604,14 @@
-
-
+
+
-
+
-
-
+
+
-
+
-@@ -752,7 +752,7 @@
+@@ -753,7 +753,7 @@
--
-+
+-
++
-@@ -792,7 +792,7 @@
+@@ -806,7 +806,7 @@
--
-+
+-
++
---- gluegen/src/java/com/jogamp/common/os/Platform.java.orig 2014-03-10 13:56:04.000000000 +0000
-+++ gluegen/src/java/com/jogamp/common/os/Platform.java 2014-05-08 18:47:51.760174681 +0000
-@@ -146,7 +146,7 @@
+--- gluegen/src/java/com/jogamp/common/os/Platform.java.orig 2014-10-10 13:20:51 UTC
++++ gluegen/src/java/com/jogamp/common/os/Platform.java
+@@ -146,7 +146,7 @@ public class Platform extends PlatformPr
private static final String useTempJarCachePropName = "jogamp.gluegen.UseTempJarCache";
/** fixed basename of JAR file and native library */
@@ -55,9 +55,9 @@
//
// static initialization order:
---- gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java.orig 2014-03-10 13:56:04.000000000 +0000
-+++ gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java 2014-05-08 18:47:51.758178183 +0000
-@@ -197,8 +197,8 @@
+--- gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java.orig 2014-10-10 13:20:51 UTC
++++ gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java
+@@ -197,8 +197,8 @@ public class TestTempJarCache extends Ju
@Test
public void testTempJarCache02AddNativeLibs() throws IOException, IllegalArgumentException, URISyntaxException {
if(AndroidVersion.isAvailable) { System.err.println("n/a on Android"); return; }
@@ -68,12 +68,3 @@
final ClassLoader cl = getClass().getClassLoader();
URI jarUriRoot = JarUtil.getJarSubURI(TempJarCache.class.getName(), cl);
-@@ -217,7 +217,7 @@
- @Test
- public void testTempJarCache03AddNativeJarLibs() throws IOException {
- if(AndroidVersion.isAvailable) { System.err.println("n/a on Android"); return; }
-- final String libBaseName = "gluegen-rt";
-+ final String libBaseName = "gluegen2-rt";
-
- JNILibLoaderBase.addNativeJarLibs(TempJarCache.class, libBaseName);
- Assert.assertTrue(JNILibLoaderBase.isLoaded(libBaseName));
diff --git a/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml b/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
index d4b19a02968e..c5eb241f6fda 100644
--- a/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
+++ b/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
@@ -1,6 +1,6 @@
---- ./jogl/make/build-common.xml.orig 2014-03-11 00:59:24.000000000 +0000
-+++ ./jogl/make/build-common.xml 2014-05-08 19:04:20.951173869 +0000
-@@ -128,8 +128,8 @@
+--- jogl/make/build-common.xml.orig 2015-03-27 14:58:50 UTC
++++ jogl/make/build-common.xml
+@@ -130,8 +130,8 @@
@@ -11,21 +11,21 @@
-@@ -208,7 +208,7 @@
+@@ -210,7 +210,7 @@
-
+
-
-
-@@ -413,7 +413,7 @@
+
+
+@@ -434,7 +434,7 @@
-
+
+
-