MFH: r466396 r466397 r466398 r466399 r466400 r466409 r466410 r466411 r466412 r466414 r466415 r466416 r466431
devel/icu: prepare consumers for 61 update https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run) Approved by: ports-secteam blanket
This commit is contained in:
parent
0f8e0598f4
commit
37cf857461
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=466433
@ -24,6 +24,7 @@ BROKEN_powerpc64= fails to compile: tags.cpp: undefined reference to TagLib::Str
|
||||
USES= compiler:c++14-lang iconv libtool localbase ncurses:port pkgconfig readline tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= glib20
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
LDFLAGS+= -lpthread
|
||||
CONFIGURE_ENV= BOOST_LIB_SUFFIX=""
|
||||
|
||||
|
31
databases/evolution-data-server/files/patch-icu61
Normal file
31
databases/evolution-data-server/files/patch-icu61
Normal file
@ -0,0 +1,31 @@
|
||||
--- src/libedataserver/e-alphabet-index-private.cpp.orig 2017-05-08 12:04:10 UTC
|
||||
+++ src/libedataserver/e-alphabet-index-private.cpp
|
||||
@@ -76,7 +76,7 @@ _e_alphabet_index_cxx_get_index (EAlphabetIndex *alph
|
||||
const gchar *word)
|
||||
{
|
||||
UErrorCode status = U_ZERO_ERROR;
|
||||
- UnicodeString string;
|
||||
+ icu::UnicodeString string;
|
||||
gint index;
|
||||
|
||||
g_return_val_if_fail (alphabet_index != NULL, -1);
|
||||
@@ -129,7 +129,7 @@ _e_alphabet_index_cxx_get_labels (EAlphabetIndex *alp
|
||||
|
||||
for (i = 0; alphabet_index->priv->nextBucket (status); i++) {
|
||||
UAlphabeticIndexLabelType label_type;
|
||||
- UnicodeString ustring;
|
||||
+ icu::UnicodeString ustring;
|
||||
std::string string;
|
||||
|
||||
label_type = alphabet_index->priv->getBucketLabelType ();
|
||||
--- src/libedataserver/e-transliterator-private.cpp.orig 2017-05-08 12:04:10 UTC
|
||||
+++ src/libedataserver/e-transliterator-private.cpp
|
||||
@@ -74,7 +74,7 @@ gchar *
|
||||
_e_transliterator_cxx_transliterate (ETransliterator *transliterator,
|
||||
const gchar *str)
|
||||
{
|
||||
- UnicodeString transform;
|
||||
+ icu::UnicodeString transform;
|
||||
std::string sourceUTF8;
|
||||
std::string targetUTF8;
|
||||
|
@ -17,4 +17,6 @@ IGNORE_WITH_PHP=70 71 72
|
||||
USES= compiler:c++11-lib php:pecl
|
||||
USE_CXXSTD= gnu++11
|
||||
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -10,4 +10,6 @@ PKGNAMESUFFIX= -intl
|
||||
USES= compiler:c++11-lib
|
||||
USE_CXXSTD= gnu++11
|
||||
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
@ -9,4 +9,6 @@ PKGNAMESUFFIX= -intl
|
||||
USES= compiler:c++11-lib
|
||||
USE_CXXSTD= gnu++11
|
||||
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
@ -9,4 +9,6 @@ PKGNAMESUFFIX= -intl
|
||||
USES= compiler:c++11-lib
|
||||
USE_CXXSTD= gnu++11
|
||||
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
283
editors/libreoffice/files/patch-icu61
Normal file
283
editors/libreoffice/files/patch-icu61
Normal file
@ -0,0 +1,283 @@
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=f7961456d81c3ee6ee4c13eac9ef7add6c7ea6b5
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=7c46e0086802c22f5a5040d9161d4d2b3b2a3aff
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=8960ecc689ce41cfaa40b65d75830d7491b06463
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=f240332f8e965ea17b70b0ccaa9990ce0a53cfc6
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=ad3b7c27cdc957a8a38876c040e86a81c3cf7003
|
||||
|
||||
--- i18npool/inc/collator_unicode.hxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/inc/collator_unicode.hxx
|
||||
@@ -63,7 +63,7 @@ class Collator_Unicode final : public cppu::WeakImplHe
|
||||
|
||||
private:
|
||||
const sal_Char *implementationName;
|
||||
- RuleBasedCollator *uca_base, *collator;
|
||||
+ icu::RuleBasedCollator *uca_base, *collator;
|
||||
#ifndef DISABLE_DYNLOADING
|
||||
oslModule hModule;
|
||||
#endif
|
||||
--- i18npool/source/breakiterator/breakiterator_unicode.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/source/breakiterator/breakiterator_unicode.cxx
|
||||
@@ -56,14 +56,14 @@ BreakIterator_Unicode::~BreakIterator_Unicode()
|
||||
}
|
||||
|
||||
/*
|
||||
- Wrapper class to provide public access to the RuleBasedBreakIterator's
|
||||
+ Wrapper class to provide public access to the icu::RuleBasedBreakIterator's
|
||||
setbreakType method.
|
||||
*/
|
||||
-class OOoRuleBasedBreakIterator : public RuleBasedBreakIterator
|
||||
+class OOoRuleBasedBreakIterator : public icu::RuleBasedBreakIterator
|
||||
{
|
||||
public:
|
||||
#if (U_ICU_VERSION_MAJOR_NUM < 58)
|
||||
- // RuleBasedBreakIterator::setBreakType() is private as of ICU 58.
|
||||
+ // icu::RuleBasedBreakIterator::setBreakType() is private as of ICU 58.
|
||||
void publicSetBreakType(int32_t type)
|
||||
{
|
||||
setBreakType(type);
|
||||
@@ -71,7 +71,7 @@ class OOoRuleBasedBreakIterator : public RuleBasedBrea
|
||||
#endif
|
||||
OOoRuleBasedBreakIterator(UDataMemory* image,
|
||||
UErrorCode &status)
|
||||
- : RuleBasedBreakIterator(image, status)
|
||||
+ : icu::RuleBasedBreakIterator(image, status)
|
||||
{ };
|
||||
|
||||
};
|
||||
@@ -334,7 +334,7 @@ sal_Int32 SAL_CALL BreakIterator_Unicode::nextCharacte
|
||||
icu::BreakIterator* pBI = character.mpValue->mpBreakIterator.get();
|
||||
for (nDone = 0; nDone < nCount; nDone++) {
|
||||
nStartPos = pBI->following(nStartPos);
|
||||
- if (nStartPos == BreakIterator::DONE)
|
||||
+ if (nStartPos == icu::BreakIterator::DONE)
|
||||
return Text.getLength();
|
||||
}
|
||||
} else { // for CHARACTER mode
|
||||
@@ -353,7 +353,7 @@ sal_Int32 SAL_CALL BreakIterator_Unicode::previousChar
|
||||
icu::BreakIterator* pBI = character.mpValue->mpBreakIterator.get();
|
||||
for (nDone = 0; nDone < nCount; nDone++) {
|
||||
nStartPos = pBI->preceding(nStartPos);
|
||||
- if (nStartPos == BreakIterator::DONE)
|
||||
+ if (nStartPos == icu::BreakIterator::DONE)
|
||||
return 0;
|
||||
}
|
||||
} else { // for BS to delete one char and CHARACTER mode.
|
||||
@@ -371,7 +371,7 @@ Boundary SAL_CALL BreakIterator_Unicode::nextWord( con
|
||||
|
||||
Boundary rv;
|
||||
rv.startPos = icuBI->mpValue->mpBreakIterator->following(nStartPos);
|
||||
- if( rv.startPos >= Text.getLength() || rv.startPos == BreakIterator::DONE )
|
||||
+ if( rv.startPos >= Text.getLength() || rv.startPos == icu::BreakIterator::DONE )
|
||||
rv.endPos = result.startPos;
|
||||
else {
|
||||
if ( (rWordType == WordType::ANYWORD_IGNOREWHITESPACES ||
|
||||
@@ -380,7 +380,7 @@ Boundary SAL_CALL BreakIterator_Unicode::nextWord( con
|
||||
rv.startPos = icuBI->mpValue->mpBreakIterator->following(rv.startPos);
|
||||
|
||||
rv.endPos = icuBI->mpValue->mpBreakIterator->following(rv.startPos);
|
||||
- if(rv.endPos == BreakIterator::DONE)
|
||||
+ if(rv.endPos == icu::BreakIterator::DONE)
|
||||
rv.endPos = rv.startPos;
|
||||
}
|
||||
return rv;
|
||||
@@ -394,7 +394,7 @@ Boundary SAL_CALL BreakIterator_Unicode::previousWord(
|
||||
|
||||
Boundary rv;
|
||||
rv.startPos = icuBI->mpValue->mpBreakIterator->preceding(nStartPos);
|
||||
- if( rv.startPos < 0 || rv.startPos == BreakIterator::DONE)
|
||||
+ if( rv.startPos < 0 || rv.startPos == icu::BreakIterator::DONE)
|
||||
rv.endPos = rv.startPos;
|
||||
else {
|
||||
if ( (rWordType == WordType::ANYWORD_IGNOREWHITESPACES ||
|
||||
@@ -403,7 +403,7 @@ Boundary SAL_CALL BreakIterator_Unicode::previousWord(
|
||||
rv.startPos = icuBI->mpValue->mpBreakIterator->preceding(rv.startPos);
|
||||
|
||||
rv.endPos = icuBI->mpValue->mpBreakIterator->following(rv.startPos);
|
||||
- if(rv.endPos == BreakIterator::DONE)
|
||||
+ if(rv.endPos == icu::BreakIterator::DONE)
|
||||
rv.endPos = rv.startPos;
|
||||
}
|
||||
return rv;
|
||||
@@ -435,9 +435,9 @@ Boundary SAL_CALL BreakIterator_Unicode::getWordBounda
|
||||
rv.endPos = icuBI->mpValue->mpBreakIterator->following(nPos);
|
||||
}
|
||||
}
|
||||
- if (rv.startPos == BreakIterator::DONE)
|
||||
+ if (rv.startPos == icu::BreakIterator::DONE)
|
||||
rv.startPos = rv.endPos;
|
||||
- else if (rv.endPos == BreakIterator::DONE)
|
||||
+ else if (rv.endPos == icu::BreakIterator::DONE)
|
||||
rv.endPos = rv.startPos;
|
||||
|
||||
return rv;
|
||||
@@ -502,7 +502,7 @@ LineBreakResults SAL_CALL BreakIterator_Unicode::getLi
|
||||
lbr.breakIndex = nStartPos;
|
||||
lbr.breakType = BreakType::WORDBOUNDARY;
|
||||
} else if (hOptions.rHyphenator.is()) { //Hyphenation break
|
||||
- sal_Int32 boundary_with_punctuation = (pLineBI->next() != BreakIterator::DONE) ? pLineBI->current() : 0;
|
||||
+ sal_Int32 boundary_with_punctuation = (pLineBI->next() != icu::BreakIterator::DONE) ? pLineBI->current() : 0;
|
||||
pLineBI->preceding(nStartPos + 1); // reset to check correct hyphenation of "word-word"
|
||||
|
||||
sal_Int32 nStartPosWordEnd = nStartPos;
|
||||
--- i18npool/source/collator/collator_unicode.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/source/collator/collator_unicode.cxx
|
||||
@@ -138,7 +138,7 @@ Collator_Unicode::loadCollatorAlgorithm(const OUString
|
||||
UErrorCode status = U_ZERO_ERROR;
|
||||
OUString rule = LocaleDataImpl::get()->getCollatorRuleByAlgorithm(rLocale, rAlgorithm);
|
||||
if (!rule.isEmpty()) {
|
||||
- collator = new RuleBasedCollator(reinterpret_cast<const UChar *>(rule.getStr()), status);
|
||||
+ collator = new icu::RuleBasedCollator(reinterpret_cast<const UChar *>(rule.getStr()), status);
|
||||
if (! U_SUCCESS(status)) throw RuntimeException();
|
||||
}
|
||||
if (!collator && OUString(LOCAL_RULE_LANGS).indexOf(rLocale.Language) >= 0) {
|
||||
@@ -343,7 +343,7 @@ Collator_Unicode::loadCollatorAlgorithm(const OUString
|
||||
size_t ruleImageSize = funclen();
|
||||
|
||||
#if (U_ICU_VERSION_MAJOR_NUM == 4) && (U_ICU_VERSION_MINOR_NUM <= 2)
|
||||
- uca_base = new RuleBasedCollator(static_cast<UChar*>(NULL), status);
|
||||
+ uca_base = new icu::RuleBasedCollator(static_cast<UChar*>(NULL), status);
|
||||
#else
|
||||
// Not only changed ICU 53.1 the API behavior that a negative
|
||||
// length (ruleImageSize) now leads to failure, but also that
|
||||
@@ -354,11 +354,11 @@ Collator_Unicode::loadCollatorAlgorithm(const OUString
|
||||
// The default collator of the en-US locale would also fulfill
|
||||
// the requirement. The collator of the actual locale or the
|
||||
// NULL (default) locale does not.
|
||||
- uca_base = static_cast<RuleBasedCollator*>(icu::Collator::createInstance(
|
||||
+ uca_base = static_cast<icu::RuleBasedCollator*>(icu::Collator::createInstance(
|
||||
icu::Locale::getRoot(), status));
|
||||
#endif
|
||||
if (! U_SUCCESS(status)) throw RuntimeException();
|
||||
- collator = new RuleBasedCollator(
|
||||
+ collator = new icu::RuleBasedCollator(
|
||||
reinterpret_cast<const uint8_t*>(ruleImage), ruleImageSize, uca_base, status);
|
||||
if (! U_SUCCESS(status)) throw RuntimeException();
|
||||
}
|
||||
@@ -372,17 +372,17 @@ Collator_Unicode::loadCollatorAlgorithm(const OUString
|
||||
*/
|
||||
icu::Locale icuLocale( LanguageTagIcu::getIcuLocale( LanguageTag( rLocale), rAlgorithm));
|
||||
// load ICU collator
|
||||
- collator = static_cast<RuleBasedCollator*>( icu::Collator::createInstance(icuLocale, status) );
|
||||
+ collator = static_cast<icu::RuleBasedCollator*>( icu::Collator::createInstance(icuLocale, status) );
|
||||
if (! U_SUCCESS(status)) throw RuntimeException();
|
||||
}
|
||||
}
|
||||
|
||||
if (options & CollatorOptions::CollatorOptions_IGNORE_CASE_ACCENT)
|
||||
- collator->setStrength(Collator::PRIMARY);
|
||||
+ collator->setStrength(icu::Collator::PRIMARY);
|
||||
else if (options & CollatorOptions::CollatorOptions_IGNORE_CASE)
|
||||
- collator->setStrength(Collator::SECONDARY);
|
||||
+ collator->setStrength(icu::Collator::SECONDARY);
|
||||
else
|
||||
- collator->setStrength(Collator::TERTIARY);
|
||||
+ collator->setStrength(icu::Collator::TERTIARY);
|
||||
|
||||
return 0;
|
||||
}
|
||||
--- i18npool/source/collator/gencoll_rule.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/source/collator/gencoll_rule.cxx
|
||||
@@ -113,7 +113,7 @@ SAL_IMPLEMENT_MAIN_WITH_ARGS(argc, argv)
|
||||
//UCollator *coll = ucol_openRules(Obuf.getStr(), Obuf.getLength(), UCOL_OFF,
|
||||
// UCOL_DEFAULT_STRENGTH, &parseError, &status);
|
||||
|
||||
- auto coll = o3tl::make_unique<RuleBasedCollator>(reinterpret_cast<const UChar *>(Obuf.getStr()), status);
|
||||
+ auto coll = o3tl::make_unique<icu::RuleBasedCollator>(reinterpret_cast<const UChar *>(Obuf.getStr()), status);
|
||||
|
||||
if (U_SUCCESS(status)) {
|
||||
std::vector<uint8_t> data;
|
||||
--- i18npool/source/ordinalsuffix/ordinalsuffix.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/source/ordinalsuffix/ordinalsuffix.cxx
|
||||
@@ -79,7 +79,7 @@ uno::Sequence< OUString > SAL_CALL OrdinalSuffixServic
|
||||
if (!U_SUCCESS(nCode))
|
||||
return retValue;
|
||||
|
||||
- std::unique_ptr<NumberFormat> xNumberFormat(icu::NumberFormat::createInstance(aIcuLocale, nCode));
|
||||
+ std::unique_ptr<icu::NumberFormat> xNumberFormat(icu::NumberFormat::createInstance(aIcuLocale, nCode));
|
||||
if (!U_SUCCESS(nCode))
|
||||
return retValue;
|
||||
|
||||
--- i18npool/source/transliteration/ignoreDiacritics_CTL.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18npool/source/transliteration/ignoreDiacritics_CTL.cxx
|
||||
@@ -35,7 +35,7 @@ ignoreDiacritics_CTL::transliterateChar2Char(sal_Unico
|
||||
if (!m_transliterator)
|
||||
throw css::uno::RuntimeException();
|
||||
|
||||
- UnicodeString aChar(nInChar);
|
||||
+ icu::UnicodeString aChar(nInChar);
|
||||
m_transliterator->transliterate(aChar);
|
||||
|
||||
if (aChar.isEmpty())
|
||||
@@ -68,7 +68,7 @@ ignoreDiacritics_CTL::folding(const OUString& rInStr,
|
||||
{
|
||||
sal_Int32 nIndex = nPosition;
|
||||
UChar32 nChar = rInStr.iterateCodePoints(&nIndex);
|
||||
- UnicodeString aUStr(nChar);
|
||||
+ icu::UnicodeString aUStr(nChar);
|
||||
m_transliterator->transliterate(aUStr);
|
||||
|
||||
if (nOffset + aUStr.length() > rOffset.getLength())
|
||||
@@ -87,7 +87,7 @@ ignoreDiacritics_CTL::folding(const OUString& rInStr,
|
||||
}
|
||||
else
|
||||
{
|
||||
- UnicodeString aUStr(reinterpret_cast<const UChar*>(rInStr.getStr()) + nStartPos, nCount);
|
||||
+ icu::UnicodeString aUStr(reinterpret_cast<const UChar*>(rInStr.getStr()) + nStartPos, nCount);
|
||||
m_transliterator->transliterate(aUStr);
|
||||
return OUString(reinterpret_cast<const sal_Unicode*>(aUStr.getBuffer()), aUStr.length());
|
||||
}
|
||||
--- i18nutil/source/utility/unicode.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ i18nutil/source/utility/unicode.cxx
|
||||
@@ -750,15 +750,15 @@ OUString SAL_CALL unicode::formatPercent(double dNumbe
|
||||
|
||||
icu::Locale aLocale = LanguageTagIcu::getIcuLocale(aLangTag);
|
||||
|
||||
- std::unique_ptr<NumberFormat> xF(
|
||||
- NumberFormat::createPercentInstance(aLocale, errorCode));
|
||||
+ std::unique_ptr<icu::NumberFormat> xF(
|
||||
+ icu::NumberFormat::createPercentInstance(aLocale, errorCode));
|
||||
if(U_FAILURE(errorCode))
|
||||
{
|
||||
- SAL_WARN("i18n", "NumberFormat::createPercentInstance failed");
|
||||
+ SAL_WARN("i18n", "icu::NumberFormat::createPercentInstance failed");
|
||||
return OUString::number(dNumber) + "%";
|
||||
}
|
||||
|
||||
- UnicodeString output;
|
||||
+ icu::UnicodeString output;
|
||||
xF->format(dNumber/100, output);
|
||||
OUString aRet(reinterpret_cast<const sal_Unicode *>(output.getBuffer()),
|
||||
output.length());
|
||||
--- lotuswordpro/source/filter/localtime.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ lotuswordpro/source/filter/localtime.cxx
|
||||
@@ -174,7 +174,7 @@ bool LtgLocalTime(long rtime,LtTm& rtm)
|
||||
|
||||
if ((rtime > 3 * DAY_SEC)&&(rtime < LONG_MAX - 3 * DAY_SEC))
|
||||
{
|
||||
- TimeZone* pLocalZone = TimeZone::createDefault();
|
||||
+ icu::TimeZone* pLocalZone = icu::TimeZone::createDefault();
|
||||
long offset = (pLocalZone->getRawOffset())/1000;
|
||||
delete pLocalZone;
|
||||
long ltime = rtime + offset;
|
||||
--- opencl/source/openclconfig.cxx.orig 2018-02-22 17:45:41 UTC
|
||||
+++ opencl/source/openclconfig.cxx
|
||||
@@ -119,7 +119,7 @@ bool match(const OUString& rPattern, const OUString& r
|
||||
UErrorCode nIcuError(U_ZERO_ERROR);
|
||||
icu::UnicodeString sIcuPattern(reinterpret_cast<const UChar*>(rPattern.getStr()), rPattern.getLength());
|
||||
icu::UnicodeString sIcuInput(reinterpret_cast<const UChar*>(rInput.getStr()), rInput.getLength());
|
||||
- RegexMatcher aMatcher(sIcuPattern, sIcuInput, 0, nIcuError);
|
||||
+ icu::RegexMatcher aMatcher(sIcuPattern, sIcuInput, 0, nIcuError);
|
||||
|
||||
return U_SUCCESS(nIcuError) && aMatcher.matches(nIcuError) && U_SUCCESS(nIcuError);
|
||||
}
|
||||
--- vcl/inc/scrptrun.h.orig 2018-02-22 17:45:41 UTC
|
||||
+++ vcl/inc/scrptrun.h
|
||||
@@ -58,7 +58,7 @@ struct ParenStackEntry
|
||||
}
|
||||
};
|
||||
|
||||
-class ScriptRun : public UObject {
|
||||
+class ScriptRun : public icu::UObject {
|
||||
public:
|
||||
|
||||
ScriptRun(const UChar chars[], int32_t length);
|
@ -29,6 +29,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
|
||||
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
|
||||
MAKE_ARGS= config=release
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
USES= compiler:c++11-lib dos2unix gmake iconv jpeg openal:al \
|
||||
pkgconfig python:build tar:xz
|
||||
USE_GNOME= libxml2 gtk20
|
||||
|
@ -58,6 +58,7 @@ USE_RC_SUBR= ${PORTNAME}
|
||||
.else
|
||||
USES+= compiler:c++11-lib
|
||||
USE_CXXSTD= gnu++11
|
||||
CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
|
||||
libicui18n.so:devel/icu \
|
||||
libicu-le-hb.so:devel/icu-le-hb \
|
||||
|
13
games/widelands/files/patch-src_graphic_text_bidi.h
Normal file
13
games/widelands/files/patch-src_graphic_text_bidi.h
Normal file
@ -0,0 +1,13 @@
|
||||
https://bazaar.launchpad.net/~widelands-dev/widelands/trunk/revision/8641
|
||||
|
||||
--- src/graphic/text/bidi.h.orig 2016-11-10 07:28:01 UTC
|
||||
+++ src/graphic/text/bidi.h
|
||||
@@ -40,7 +40,7 @@ bool has_rtl_character(std::vector<std::string> input)
|
||||
// True if a string contains a character from the script's code blocks
|
||||
bool has_script_character(const char* input, UI::FontSets::Selector script);
|
||||
UI::FontSet const* find_fontset(const char* word, const UI::FontSets& fontsets);
|
||||
-std::string icustring2string(const UnicodeString& convertme);
|
||||
+std::string icustring2string(const icu::UnicodeString& convertme);
|
||||
std::string icuchar2string(const UChar& convertme);
|
||||
bool cannot_start_line(const UChar& c);
|
||||
bool cannot_end_line(const UChar& c);
|
@ -8,6 +8,9 @@ PORTREVISION= 16
|
||||
CATEGORIES= graphics geography
|
||||
MASTER_SITES= http://mapnik.s3.amazonaws.com/dist/v${PORTVERSION}/
|
||||
|
||||
PATCH_SITES= https://github.com/mapnik/mapnik/commit/
|
||||
PATCHFILES= 1ddfe6c31548.patch:-p1
|
||||
|
||||
MAINTAINER= littlesavage@rambler.ru
|
||||
COMMENT= Free Toolkit For Developing Mapping Applications
|
||||
|
||||
|
@ -1,2 +1,5 @@
|
||||
TIMESTAMP = 1448548335
|
||||
SHA256 (mapnik-v3.0.9.tar.bz2) = 3a3f67532b05f8a527a5bab32effd7dd5aa59165c7e24505268f6d827955d3da
|
||||
SIZE (mapnik-v3.0.9.tar.bz2) = 75213927
|
||||
SHA256 (1ddfe6c31548.patch) = fab754996485dc607108a4fd69d0df82414928eb5a210b329a84f47e90da0c8a
|
||||
SIZE (1ddfe6c31548.patch) = 2148
|
||||
|
@ -16,6 +16,7 @@ BUILD_DEPENDS= cppunit-config:devel/cppunit
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-conf --with-zlib
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= gmake libtool pathfix pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -28,6 +28,7 @@ WX_CONF_ARGS= absolute
|
||||
USE_GL= gl
|
||||
USE_CSTD= c99
|
||||
USE_CXXSTD= c++11
|
||||
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
|
||||
LDFLAGS+= -Wl,--as-needed # freetype
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -6,6 +6,9 @@ PORTREVISION= 1
|
||||
CATEGORIES= textproc rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
PATCH_SITES= https://github.com/brianmario/charlock_holmes/commit/
|
||||
PATCHFILES= 018be8532670.patch:-p1
|
||||
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
COMMENT= Gems for character encoding detection
|
||||
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1504489308
|
||||
SHA256 (rubygem/charlock_holmes-0.7.5.gem) = 9e942575e702c96e3747f494756a72eee008a185d6c7ebd1049c4dd0b529b625
|
||||
SIZE (rubygem/charlock_holmes-0.7.5.gem) = 10752
|
||||
SHA256 (rubygem/018be8532670.patch) = f54871c047f27ad057720c1f3ef7578bb87edc2c9e5ee3623a3d26b9dde40f13
|
||||
SIZE (rubygem/018be8532670.patch) = 2324
|
||||
|
@ -41,6 +41,7 @@ USES= cmake:outsource compiler:c++11-lib libedit
|
||||
USE_GNOME= libxml2 libxslt
|
||||
USE_LDCONFIG= yes
|
||||
USE_CXXSTD= c++11
|
||||
CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
|
||||
CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
|
||||
|
@ -7,6 +7,9 @@ CATEGORIES= www
|
||||
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
|
||||
PKGNAMESUFFIX= 8
|
||||
|
||||
PATCH_SITES= https://github.com/nodejs/node/commit/
|
||||
PATCHFILES= b8f47b27571f.patch:-p1
|
||||
|
||||
MAINTAINER= bhughes@FreeBSD.org
|
||||
COMMENT= V8 JavaScript for client and server (8.x LTS)
|
||||
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1522526743
|
||||
SHA256 (node-v8.11.1.tar.gz) = 86678028f13b26ceed08efc4b838921ca1bf514c0b7e8151bfec8ba15c5e66ad
|
||||
SIZE (node-v8.11.1.tar.gz) = 31030225
|
||||
SHA256 (b8f47b27571f.patch) = b0b22c490c4b4e7ed4bad46d1989e980a0ba30299855ec0164ff3d11384833c7
|
||||
SIZE (b8f47b27571f.patch) = 4763
|
||||
|
Loading…
Reference in New Issue
Block a user