New port: p5-Net-Z3950:

This Perl module provides interface to the Z39.50 information
retrieval protocol (aka ISO 23950), a mature and powerful protocol
used in application domains as diverse as bibliographic information,
geo-spatial mapping, museums and other cultural heritage information,
and structured vocabulary navigation.
This commit is contained in:
Dmitry Sivachenko 2001-12-23 21:23:49 +00:00
parent 95dd100c0d
commit 2c1e95715c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52062
7 changed files with 66 additions and 0 deletions

View File

@ -306,6 +306,7 @@
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
SUBDIR += p5-Net-XWhois
SUBDIR += p5-Net-Z3950
SUBDIR += p5-Net-ext
SUBDIR += p5-NetAddr-IP
SUBDIR += p5-NetAddr-IP-Count

29
net/p5-Net-Z3950/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: p5-Net-RawIP
# Date created: 23 December 2001
# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Net-Z3950
PORTVERSION= 0.22
CATEGORIES= net perl5
MASTER_SITES= http://perl.z3950.org/download/
PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
LIB_DEPENDS= yaz.1:${PORTSDIR}/net/yaz
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MARC.pm:${PORTSDIR}/textproc/p5-MARC \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
PERL_CONFIGURE= yes
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
MAN3= Net::Z3950::ResultSet.3 Net::Z3950::Manager.3 \
Net::Z3950::Tutorial.3 Net::Z3950::Record.3 \
Net::Z3950::Connection.3 Net::Z3950::APDU.3 Net::Z3950.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Net-Z3950-0.22.tar.gz) = 220355216ebae55e990103b36911b894

View File

@ -0,0 +1,14 @@
--- Makefile.PL.orig Sun Dec 23 23:08:17 2001
+++ Makefile.PL Sun Dec 23 23:09:10 2001
@@ -7,9 +7,9 @@
'NAME' => 'Net::Z3950',
'VERSION_FROM' => 'Z3950.pm', # finds $VERSION
# 'LIBS' => ['-L/usr/local/src/yaz/lib/.libs -lyaz'], # e.g., '-lm'
- 'LIBS' => ['-lyaz'], # e.g., '-lm'
+ 'LIBS' => ["-L$ENV{LOCALBASE}/lib -lyaz"], # e.g., '-lm'
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
-# 'INC' => '-I/usr/local/src/yaz/include',
+ 'INC' => "-I$ENV{LOCALBASE}/include",
'PREREQ_PM' => { Event => 0.77 },
'MYEXTLIB' => 'yazwrap/libyazwrap$(LIB_EXT)',
);

View File

@ -0,0 +1 @@
A perl interface to the Z39.50 information retrieval protocol

View File

@ -0,0 +1,7 @@
This Perl module provides interface to the Z39.50 information
retrieval protocol (aka ISO 23950), a mature and powerful protocol
used in application domains as diverse as bibliographic information,
geo-spatial mapping, museums and other cultural heritage information,
and structured vocabulary navigation.
WWW: http://perl.z3950.org/

View File

@ -0,0 +1,13 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/APDU.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Connection.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Manager.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Record.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/ResultSet.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Tutorial.pm
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950