- Update to 0.9.2

PR:		ports/61880, ports/61897
Submitted by:	Kay Lehmann <kay_lehmann@web.de> (maintainer)
This commit is contained in:
Pav Lucistnik 2004-01-25 18:59:24 +00:00
parent ccaa4bdb49
commit 28be86e0f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99108
9 changed files with 77 additions and 48 deletions

View File

@ -6,12 +6,10 @@
#
PORTNAME= prokyon3
PORTVERSION= 0.9.1.r1
PORTREVISION= 1
PORTVERSION= 0.9.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-r/}
MAINTAINER= kay_lehmann@web.de
COMMENT= Prokyon3 is a multithreaded MP3 manager and tag editor
@ -21,17 +19,41 @@ LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib \
vorbis.3:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_QT_VER= 3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
CONFIGURE_ARGS+= --with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
--with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
USE_GETOPT_LONG=yes
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
--with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500041
QT_NONSTANDARD= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include \
-I${QT_PREFIX}/include"
.endif
.if defined(WITH_BURN)
RUN_DEPENDS+= cdrecord:${PORTSDIR}/sysutils/cdrtools \
mpg123:${PORTSDIR}/audio/mpg123 \
ogg123:${PORTSDIR}/audio/vorbis-tools \
normalize:${PORTSDIR}/audio/normalize \
bash:${PORTSDIR}/shells/bash2
PLIST_FILES+= bin/prokburn
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-g -O2|${CFLAGS}|; s|-lqt-mt|-lqt-mt ${PTHREAD_LIBS}|' ${WRKSRC}/configure
.if !defined(WITH_BURN)
@${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
post-install:
@${CAT} ${PKGMESSAGE}
@sleep 5
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (prokyon3-0.9.1-r1.tar.gz) = 767f849e9ba4c5c4ec114f64ecf1824b
MD5 (prokyon3-0.9.2.tar.gz) = 49e7b2662f4fffc3c366c4fb0ff53d4c

View File

@ -1,18 +0,0 @@
--- src/getopt.h.orig Sun Dec 8 19:29:14 2002
+++ src/getopt.h Mon Nov 24 21:07:44 2003
@@ -15,9 +15,6 @@
along with this program; if not, write to the Free Software
Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
-#ifndef _GETOPT_H
-#define _GETOPT_H 1
-
#ifdef __cplusplus
extern "C" {
#endif
@@ -125,5 +122,3 @@
#ifdef __cplusplus
}
#endif
-
-#endif /* _GETOPT_H */

View File

@ -1,11 +0,0 @@
--- src/tagger_mp3.cpp.orig Mon Feb 17 00:01:44 2003
+++ src/tagger_mp3.cpp Mon Nov 24 21:00:58 2003
@@ -448,7 +448,7 @@
if(mp3->id3.comment[28] == '\0') {
mp3->id3.track[0] = mp3->id3.comment[29];
}
- mp3->file.readBlock(&(char)mp3->id3.genre[0], 1);
+ mp3->file.readBlock((char*)&mp3->id3.genre[0], 1);
unpad(mp3->id3.title);
unpad(mp3->id3.artist);
unpad(mp3->id3.album);

View File

@ -0,0 +1,11 @@
--- src/getopt.c.orig Sat Sep 20 10:34:30 2003
+++ src/getopt.c Sat Sep 20 10:35:56 2003
@@ -24,6 +24,8 @@
#include "config.h"
#endif
+#define _(String)(String)
+
#ifndef __STDC__
/* This is a separate conditional since some stdc systems
reject `defined (const)'. */

View File

@ -0,0 +1,8 @@
--- prokburn.orig Sun Jan 25 11:25:18 2004
+++ prokburn Sun Jan 25 11:25:41 2004
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/local/bin/bash
####################################################################################"
# A small bash utility to burn CD from prokyon3.
# PH FERME

View File

@ -1,10 +1,8 @@
prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
It was written in C++ using the Qt3 widget set and the MySQL database.
prokyon3 can access MP3 files on harddisk, CDROM, SMB and NFS. Files
can be played using XMMS, and can even be played when the files are on
CD as prokyon3 identifies CDs by content. The files view is customizable
and favorite artists are supported. prokyon3 also offers an editor for
ID3 tags and has been designed to support tagging for multiple files en
prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
It was written in C++ using the Qt3 widget set and the MySQL database.
prokyon3 can access MP3 files on harddisk, CDROM, SMB and NFS. Files
can be played using XMMS, and can even be played when the files are on
CD as prokyon3 identifies CDs by content. The files view is customizable
and favorite artists are supported. prokyon3 also offers an editor for
ID3 tags and has been designed to support tagging for multiple files en
masse.
WWW: http://prokyon3.sourceforge.net/

View File

@ -0,0 +1,5 @@
WARNING:
prokyon-0.9.2 introduces rudimental burning-support, which needs to be
enabled using WITH_BURN=yes when installing this port. This feature
hasn't been tested at all. So you have been warned when anything weird
happens using this feature.

View File

@ -29,5 +29,19 @@ share/prokyon3/images/madsmiley.png
share/prokyon3/images/pink_marble.png
share/prokyon3/images/smiley.png
share/prokyon3/images/splash4.png
share/locale/de/LC_MESSAGES/prokyon3.mo
share/locale/fr/LC_MESSAGES/prokyon3.mo
share/locale/nl/LC_MESSAGES/prokyon3.mo
share/prokyon3/images/action_burncd.png
share/prokyon3/images/action_documentation.png
share/prokyon3/html/manual_one_file/images/docbook/important.png
share/prokyon3/html/manual_one_file/images/docbook/note.png
share/prokyon3/html/manual_one_file/images/docbook/tip.png
share/prokyon3/html/manual_one_file/images/docbook/warning.png
share/prokyon3/html/manual_one_file/index.html
@dirrm share/prokyon3/images
@dirrm share/prokyon3/html/manual_one_file/images/docbook
@dirrm share/prokyon3/html/manual_one_file/images
@dirrm share/prokyon3/html/manual_one_file
@dirrm share/prokyon3/html
@dirrm share/prokyon3