upgrade to 2.43

This commit is contained in:
Andrey A. Chernov 1999-02-17 22:25:40 +00:00
parent 7ef9e7065f
commit 1965e617b5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16751
5 changed files with 44 additions and 19 deletions

View File

@ -1,22 +1,23 @@
# New ports collection makefile for: unarj
# Version required: 2.41
# Version required: 2.4*
# Date created: 28 Dec 1994
# Whom: ache
#
# $Id: Makefile,v 1.10 1998/08/18 22:56:50 asami Exp $
# $Id: Makefile,v 1.11 1998/09/23 01:00:52 steve Exp $
#
DISTNAME= unarj241
PKGNAME= unarj-2.41
DISTNAME= unarj-2.43
CATEGORIES= archivers
MASTER_SITES= ftp://garbo.uwasa.fi/unix/arcers/
EXTRACT_SUFX= .tar.Z
MASTER_SITES= ftp://ftp.kiarchive.ru/pub/unix/arcers/
EXTRACT_SUFX= .tgz
MAINTAINER= ache@FreeBSD.ORG
WRKSRC= ${WRKDIR}/unarj
do-install:
${INSTALL} -d -m 755 -o $(SHAREOWN) -g ${SHAREGRP} \
${PREFIX}/share/doc/unarj
cd ${WRKSRC}; ${INSTALL_PROGRAM} unarj ${PREFIX}/bin
cd ${WRKSRC}; ${INSTALL_DATA} unarj.doc technote.doc \
${PREFIX}/share/doc/unarj
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (unarj241.tar.Z) = 19d0849fa336847a49206778f1c61953
MD5 (unarj-2.43.tgz) = 5240b3c376a3ecac692246c9c482d8c7

View File

@ -1,6 +1,6 @@
--- unarj.h.orig Wed Jun 23 06:07:20 1993
+++ unarj.h Wed Jan 21 15:03:39 1998
@@ -104,9 +104,13 @@
--- unarj.h.orig Mon Sep 29 14:00:24 1997
+++ unarj.h Thu Feb 18 01:06:10 1999
@@ -106,8 +106,12 @@
#endif
typedef unsigned char uchar; /* 8 bits or more */
@ -13,4 +13,3 @@
typedef unsigned long ulong; /* 32 bits or more */
#define USHRT_BIT (CHAR_BIT * sizeof(ushort))

View File

@ -1,6 +1,6 @@
--- environ.c.orig Tue Jun 22 22:07:20 1993
+++ environ.c Sat Dec 26 08:39:07 1998
@@ -429,16 +429,23 @@
--- environ.c.orig Mon Sep 29 14:00:24 1997
+++ environ.c Thu Feb 18 01:14:35 1999
@@ -430,16 +430,24 @@
#define SUBS_DEFINED
@ -8,6 +8,7 @@
+#include <string.h>
#include <time.h>
+#include <sys/types.h>
+#include <utime.h>
-#ifndef time_t
-#define time_t long
@ -27,7 +28,7 @@
FILE *
file_open(name, mode)
@@ -534,8 +541,12 @@
@@ -535,8 +543,12 @@
}
long
@ -41,7 +42,7 @@
#define NOONOFFSET 43200L
#define SEC_IN_DAY (24L * 60L * 60L)
#define INV_VALUE (SEC_IN_DAY + 1L)
@@ -551,6 +562,7 @@
@@ -552,6 +564,7 @@
noontm = localtime(&noon);
retval = NOONOFFSET - 60 * (60 * noontm->tm_hour - noontm->tm_min);
return retval;
@ -49,7 +50,20 @@
}
long
@@ -608,7 +620,8 @@
@@ -600,19 +613,29 @@
{
time_t m_time;
struct utimbuf
+#ifndef __FreeBSD__
{
time_t atime; /* New access time */
time_t mtime; /* New modification time */
} tb;
+#else
+ tb;
+#endif
(char *) name;
(uint) attribute;
(uint) host;
@ -57,5 +71,13 @@
+ m_time = mstonix(tstamp);
+ m_time += gettz(m_time);
+#ifndef __FreeBSD__
tb.mtime = m_time; /* Set modification time */
tb.atime = m_time; /* Set access time */
+#else
+ tb.modtime = m_time; /* Set modification time */
+ tb.actime = m_time; /* Set access time */
+#endif
/* set the time stamp on the file */
return utime(name, &tb);

View File

@ -1 +1,4 @@
bin/unarj
share/doc/unarj/unarj.doc
share/doc/unarj/technote.doc
@dirrm share/doc/unarj