The bibutils program set interconverts between various bibliography

formats using a common MODS-format XML intermediate. For example, one
can convert RIS-format files to Bibtex by doing two transformations:
RIS->MODS->Bibtex. By using a common intermediate for N formats, only 2N
programs are required and not N^2-N. These programs operate on the
command line and are styled after standard UNIX-like filters.

WWW: http://www.scripps.edu/~cdputnam/software/bibutils/
This commit is contained in:
Gabor Pali 2010-05-15 15:24:06 +00:00
parent 6d53c3da65
commit 09f4731167
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=254353
6 changed files with 73 additions and 0 deletions

View File

@ -36,6 +36,7 @@
SUBDIR += bib2html
SUBDIR += bibtex2html
SUBDIR += bibtool
SUBDIR += bibutils
SUBDIR += bn-aspell
SUBDIR += bomstrip
SUBDIR += br-aspell

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: bibutils
# Date created: May 14, 2010
# Whom: Gabor Pali <pgj@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= bibutils
PORTVERSION= 4.9
CATEGORIES= textproc
MASTER_SITES= http://www.scripps.edu/~cdputnam/software/bibutils/
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
EXTRACT_SUFX= .tgz
MAINTAINER= pgj@FreeBSD.org
COMMENT= Program set interconverts between various bibliography formats
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
post-patch:
@${REINPLACE_CMD} 's|make |gmake |g' \
${WRKSRC}/Makefile_start
do-configure:
@cd ${WRKSRC} && ./configure --install-dir ${PREFIX}/bin
test: all
cd ${WRKSRC}/test && ${GMAKE} all test
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (bibutils_4.9_src.tgz) = 1cc0724b821ae9749b91a267207105dc
SHA256 (bibutils_4.9_src.tgz) = 86914a11330f7b4bf196bc44028b14fddbce8cd0058bd6c1bb1cfce7bb0b8287
SIZE (bibutils_4.9_src.tgz) = 513810

View File

@ -0,0 +1,10 @@
--- ./Makefile_start.orig 2010-04-08 18:31:00.000000000 +0200
+++ ./Makefile_start 2010-05-15 00:21:58.000000000 +0200
@@ -34,6 +34,7 @@
@for p in ${PROGRAMS}; \
do ( cp bin/$$p ${INSTALLDIR}/$$p ); \
done
+ cp lib/libbibutils.a ${INSTALLDIR}/../lib
package: all FORCE
csh -f maketgz.csh ${VERSION} ${POSTFIX}

View File

@ -0,0 +1,8 @@
The bibutils program set interconverts between various bibliography
formats using a common MODS-format XML intermediate. For example, one
can convert RIS-format files to Bibtex by doing two transformations:
RIS->MODS->Bibtex. By using a common intermediate for N formats, only 2N
programs are required and not N^2-N. These programs operate on the
command line and are styled after standard UNIX-like filters.
WWW: http://www.scripps.edu/~cdputnam/software/bibutils/

View File

@ -0,0 +1,19 @@
@comment $FreeBSD$
bin/bib2xml
bin/biblatex2xml
bin/copac2xml
bin/ebi2xml
bin/end2xml
bin/endx2xml
bin/isi2xml
bin/med2xml
bin/modsclean
bin/ris2xml
bin/wordbib2xml
bin/xml2ads
bin/xml2bib
bin/xml2end
bin/xml2isi
bin/xml2ris
bin/xml2wordbib
lib/libbibutils.a