1
0
mirror of https://github.com/profanity-im/profanity.git synced 2024-07-14 18:14:15 -04:00
profanity/Dockerfile.ubuntu
Michael Vetter 50f0cfd324 ci: git clone from https
```
Cloning into 'stabber'...
fatal: remote error:
  The unauthenticated git protocol on port 9418 is no longer supported.
Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
```
2022-01-11 16:16:12 +01:00

54 lines
1.1 KiB
Docker

FROM ubuntu:latest
ENV DEBIAN_FRONTEND="noninteractive"
RUN apt-get update && apt-get install -y --no-install-recommends \
autoconf \
autoconf-archive \
automake \
expect \
gcc \
git \
libcmocka-dev \
libcurl3-dev \
libgcrypt-dev \
libglib2.0-dev \
libgpgme11-dev \
libgtk2.0-dev \
libmicrohttpd-dev \
libncursesw5-dev \
libnotify-dev \
libotr5-dev \
libreadline-dev \
libsignal-protocol-c-dev \
libssl-dev \
libtool \
libxss-dev \
make \
pkg-config \
python3-dev \
python-dev-is-python3 \
libsqlite3-dev
RUN mkdir -p /usr/src/{stabber,libstrophe,profanity}
WORKDIR /usr/src
RUN git clone https://github.com/boothj5/stabber
RUN git clone https://github.com/strophe/libstrophe
# TODO: Re-enable once libmicrohttpd-dev has been updated.
#WORKDIR /usr/src/stabber
#RUN ./bootstrap.sh
#RUN ./configure --prefix=/usr --disable-dependency-tracking
#RUN make
#RUN make install
WORKDIR /usr/src/libstrophe
RUN ./bootstrap.sh
RUN ./configure --prefix=/usr
RUN make
RUN make install
WORKDIR /usr/src/profanity
COPY . /usr/src/profanity