confix/modules/packages/river-bsp-layout/shell.nix
2024-02-21 08:24:20 -08:00

12 lines
295 B
Nix

{ pkgs ? import <nixpkgs> { } }:
pkgs.mkShell {
# Get dependencies from the main package
inputsFrom = [ (pkgs.callPackage ./default.nix { }) ];
# Additional tooling
buildInputs = with pkgs; [
rust-analyzer # LSP Server
rustfmt # Formatter
clippy # Linter
];
}